This project has moved and is read-only. For the latest updates, please go here.

Can't get sample plugins to work

Sep 24, 2008 at 2:15 PM
I'm totally new to VST.NET.
I have downloaded the "VST.NET Samples Source Code and Help".
I use host.
All sorts of plugins that i have found on the internet work with this host without any issues, but when I try to load Jacobi.vst.Delay.dll nothing happens.
What am I doing wrong?
Thanks in advance for any support.
Sep 24, 2008 at 3:17 PM
Ok, nevermind, I got confused by the documentation as I am not an English native speaker.

Sep 25, 2008 at 5:37 PM
Did you get confused by the VST.NET documentation or your Host's?

If it was the VST.NET documentation that was not clear, could you please indicate the section?
Then I can fix it.

Dec 2, 2008 at 9:19 PM

I also suffer from the same problem. I only downloaded the examples (I haven't installed visual studio yet) and cannot get the VST plugin to get recognized in my host (ableton live 7.0.12).
Do I need to do something special? If so, could you please let me know what to do?
I have tried dragging (as an admin in windows vista) to the windows/assembly directory but it fails to do so.

I haven't seen any instructions on how to do this in either the .chm help file, nor in the Home-->VST Samples section.

Any help would be greatly appreciated.


PS. Many thanks for your wonderful effort in this project!
Dec 3, 2008 at 7:26 PM
Hi Dimitris,

I'm not that very familiar with Live 7, but in the Preferences dialog (from menu) on the File Folder tab there is a VST Plugin Custom folder setting with a browse button next to it. I think I managed to get it working to point that folder to my "_SharedAssemblies" folder...

I also renamed all *.net.dll files (that contain the managed plugin code) to *.net.vstdll. This will prevent the host from trying to load the dll's that are not actual VST plugins. The Loader will load both .net.dll as .net.vstdll assemblies.

It is a known defect that the CorePlugin sample does not load/run correctly in Ableton Live. I have no idea why this is and have had no time to find out why.

Hope this will get you going.
Dec 8, 2008 at 6:14 AM
I'm also having trouble getting the sample vst recognized by cakewalk. I'm using the 0.5 bin release.

I took Jacobi.Vst.Interop.dll and renamed it to DelayTest.dll

Then I took the Jacobi.Vst.Samples.Delay.dll and renamed it to 

Both of these went into the Cakewalk VST directory. Upon a re-scan in cakewalk, it complains that "DelayTest" had a failure point that was reported as "Main Call"

Note I wasn't able to install the Core & Framework DLLs into GAC for a reason I cannot yet figure out. Is the reason the cakewalk is complaining due to the fact that the core dll isn't in the gac? Is anyone aware if this has been used with Cakewalk?

Thanks, looks really, really promising.
Dec 9, 2008 at 6:05 AM
Here's a quick update. 

I took Jacobi.Vst.Interop.dll and renamed it to DelayTest.dll

I took the Jacobi.Vst.Samples.Delay.dll and renamed it to

I copied the dll from the core and framework dirs to the same directory as above. Thus, there were 4 dlls in total in that directory. And again, the directory was a sub dir in a vst dir that cakewalk had setup.

Upon scan, cakewalk asked zero questions. It's looks to not care about other dlls in the dir, so no need to use the vstdll naming.

Upon re-scan completion, I was able to drop the delay into an effects biin. However, it's not delay. But I did see the simple delay UI come up. It's making some zipper noise when the delay slider is adjusted, and the left audio seems to go quite when the delay is activated. I'll try to figure out what's up next when I try to build my own dlls.

But for those with cakewalk, it loads no problem.
Dec 9, 2008 at 4:05 PM
Hi Seattledev,

The Core and the Framework assemblies should be either in the GAC or in the same folder as the renamed interop assembly (DelayTest.dll in your case). So that is probably the reason why it worked in you second scenario. It is strange you can't register the assemblies in the GAC though. Try the Core first and then the Framework assembly (Framework is dependend on Core). Just drag and drop them in the Windows/assembly folder.

I cannot explain the zipper noise. I never tested with cakewalk though. I primarily used vsthost.exe for testing. One way to find out what is happening is attaching a debugger (visual studio for instance) to the cakewalk process and set break points in the sample code.

Keep us posted how you're doing.
Jan 22, 2009 at 3:37 PM
Hi obiwanjacobi,

Even a newbie like me, using the instructions in this thread, could get the Delay VST up and running in no time! Great :-)
When trying to pull the same trick for the Sample player VSTi, the following error popped up in the host (Reaper):

System.InvalidOperationException: The plugin returned a name that is too long.
by Jacobi.Vst.Framework.Plugin.StdPluginCommandStub.GetEffectName()
by PluginCommandProxy.Dispatch(Int32 opcode, Int32 index, Int32 value, Void% ptr, Single opt)

Jan 23, 2009 at 7:46 AM

I think you've found a bug.

Go into the source code of the sample and reduce the size of the effect name. Recompile and you should be ok.

I will fix this in the next release.