This project has moved. For the latest updates, please go here.

Can't get it running on Win7 32bit

Sep 24, 2010 at 9:38 AM

I couldn't use any of example plugins (not to mention my own ones). I tried some hosts including FL Studio and Adobe Audition, but with no luck. Everything tells almost nothing when I try to load a plugin and hosts are just freezing when I try to close them. The only thing to mention is FL's rare “Internal exception 0x_SOMETHING_”. I checked if it's missing VS2008 redistributables but all DLL dependencies are ok. What's wrong?

Sep 24, 2010 at 2:17 PM

Hello!

Tried with other win OS (XP)? In fact I don't see any reason why this thing (vst.net by itself) would not run with W7. Get the latest source code (vstnet-48968) compile it, type correct probe paths (in config files) and it should work... Well... at least it works on my comp (cubase, wave lab, vst host). The only problem with w7 (and vista also) might be security policy - user is not welcome to do much things in C:\Program Files\Steinberg\Vstplugins or any other reserved folder.

Common daw's check all plugins in plugin folder (by opening each one) on each start. So, if some of them is ustable or defect it might also affect or crash the host. Hope it helps.

 Regards, kasaudio

Coordinator
Sep 26, 2010 at 10:39 AM

Not sure whats wrong. I never tried that scenario before.

As soon as I know more, I will let you know.

Oct 2, 2010 at 1:15 AM
Edited Oct 2, 2010 at 1:16 AM

I don't know about the plugins but my Vst.Net host works on Windows 7 64 bit when I set compile target to x86 32 bits.