This project has moved. For the latest updates, please go here.

Help with Samples

Topics: Newbie
Sep 24, 2011 at 7:34 PM

Hi, I've just downloaded the library & samples. The whole thing looks very interesting but i'm having trouble getting going.

I run Cubase 32bit & 64bit versions on my Win7 64bit pc (i'm only using the 32bit version for VST.Net tho). I have put the framework & core dlls in the GAC. I have copied the following files into my vst folder:

Jacobi.Vst.Samples.Delay.dll

Jacobi.Vst.Samples.Delay.net.vstdll

But nothing gets picked up by Cubase. I have tried also adding Jacobi.Vst.Samples.CorePlugin.net.vstdll but still no joy. I'd be grateful if someone can point me in the right direction. Has anyone else got VST.Net to work on Win7 64bit? Thanks in advance for any help provided.

PS I tried installing the package for VC90.CRT but the installer said it was already installed.

Sep 25, 2011 at 3:11 AM

Have you tried with other hosts than cubase? I run VST.Net as a host under Win7 64 bit with the 32 bit binairies, never tried the plugin. Maybe try clearing the GAC and re-install.

Sep 25, 2011 at 5:39 PM

Thanks for the help Yury but i'm still stuck. I've tried another host (Ableton) but that didn't detect it either. I have tried the VST.Net host but this immediately fails on both my Win7 64 bit machines and on my Win XP machine.

I think i'm going to have to leave it for now unless anyone has any ideas. Thanks again for your help.

Cheers.

Sep 25, 2011 at 6:15 PM

BTW, I've also tried with VSTHost and that doesn't pickup anything either.

Sep 26, 2011 at 1:12 AM

I still got plenty of ideas, if you're still trying to resolve this issue. A good starting point would be pinpointing when then why the plugin fails. You can use the 'Host' program in Vst.Net source code to load a plugin while debugging. Just put all your DLL in the debug folder and catch appropriate exception in the "Load Plugin" button event handler.

Coordinator
Sep 26, 2011 at 6:52 AM

Hi Teargas (nice name! ;-)

Understand that for a native VST Host the Jacobi.Vst.Samples.Delay.dll is the plugin. It is in fact the Jacobi.Vst.Interop renamed to mach the name of the plugin. The .net.vstdll file contains the managed code of the plugin itself. So try pointing the host to the dll file instead of the .net.vstdll file.

Further, you don't have to put the Core and Framework assemblies in the GAC. Just put them next to the the other plugin files.

Also some hosts require you to manually refresh the plugin cache. Look for an option called "rescan" or something similar.

Start with VstHost.exe because that is the same host I use for testing. Add the plugin by browsing to the .dll file. If it still doesn't work, please provide a detailed report of your actions.

So hang in there, we will get it working ;-)

Hope it helps.
Marc

Sep 26, 2011 at 10:57 AM

Its working! Thanks for your help guys. I'm sure i tried this configuration before - maybe not otherwise it would've worked!). For the benefit of any others that have had trouble getting the demo projects working, here is a list of what i did:

  • Download the VST.Net package.
  • Create a new empty folder somewhere.
  • Copy Jacobi.Vst.Core.dll (from Binaries\Release\Jacobi.Vst.Core) into the new folder.
  • Copy Jacobi.Vst.Framework.dll (from Binaries\Release\Jacobi.Vst.Framework).
  • Copy Jacobi.Vst.Samples.Delay.dll & Jacobi.Vst.Samples.Delay.net.vstdll (fromBinaries\Release).
  • Download VSTHost if you haven't already go it (search http://www.kvraudio.com for links to this).
  • Open VSTHost and Click File / Set Plugin path and set it to the newly created directory.
  • Select File / Rescan Plugins (this ususally gets done by default).
  • Select File / Plugins - the VST.Net Code Sample Delay effect should now be in the list.

Once you've verified its all working, you can then move on to setting it up properly with your usual VST host e.g. Cubase.

Thanks again for the help. Now on to development!

Coordinator
Sep 27, 2011 at 5:25 PM
Edited Sep 27, 2011 at 5:25 PM

Good to hear you've got it working.

Have fun with it and don't hesitate to post your questions - or results for that matter ;-)