This project has moved and is read-only. For the latest updates, please go here.

Midi Note Mapper Usage creates Cubase5 warning and freezes

Aug 8, 2009 at 2:07 AM

Sorry everyone fairly amateur at this stuff!    I thought I'd compile and build the demo's and load into my Cubase 5 (Vista 64) and use this as my starting point.     

I've followed the build instructions as best I can understand them, and all seems to be recognised when I run up Cubase.    When I select the "Midi Note Sampler" it seems to be accepted as an instrument on a Midi track and the Plug in user interface seems to behave OK ... but I have not tested its functionality.  

When I try the same for the Midi note mapper I get a warning from Cubase 5 ...

ST Mixer Warnings (Saturday, August 08, 2009)
This mixer configuration expected "Jacobi.Vst.Samples.MidiNoteMapper" to have Output 1: Stereo, 
     -> The instrument currently has Output 1: , 
     -> The instrument channel will be silent.

Any interaction with the plugin editor eg Clicking anywhere on it or pressing the "e" button in Cubase to hide it or the "x" button on the form
causes Cubase to lock up "Not responding".  

Any ideas?



Aug 10, 2009 at 7:27 PM

I just thought I'd add to my previous observations.    Although I have seen the previously stated initialisation whinge from Cubase a few times it does not seem to be easily repeatable.

I thought I'd try downloading your release version rather than the latest ... VST.NET 0.7 (18964) and just do the installation of the DLLs without use of Visual Studio compilation at all so hopefully I've not messed things up.    I found that Cubase recognised the 4 sample DLLs and I could create a new project, and add the Midi Note Sampler to the VST Instruments panel and let Cubase create and associate it with a new midi track.    Pressing the "e" edit button on the VST Instruments panel seems to work OK for this, and the Note Sampler GUI disappears and re-appears as expected.  

If the same is tried for the Mapper then when the "e" is pressed the GUI window of the mapper does not go away and Cubase and the mapper window are "Not responding" and the whole lot has to be killed with the task manager.   Closing the mapper gui with the "X" close box also creates the same problem.    Also interesting is that as soon as the mapper is added to the VST Instruments panel (even before a midi track is created) the audio "stereo out" meter goes to max with clip warning on both channels and stays there even if I try turning the volume right down.    I've not tried listening to this through my XS8!   

If I create an audio track in a new project and add the Delay to the inserts on this track the "e" button on the track insert and the "x" close box seem to work as expected.     Interestingly, as soon as I put this "audio" Delay insert in place, the Midi out monitor on the Cubase Transport starts showing usage, if I switch on the insert bypass, the Midi usage stops.   As said earlier ... I'm certainly not an expert but would not have expected that.

Adding the Core Plug-in sample also has the same "closure" problem as the Mapper.

I really would like to try some C# VST development and I'm hoping this is not simply a Cubase 5, 64 bit or Vista issue which cannot be cured.    If I can help with any diagnostics then please let me know.


Aug 17, 2009 at 11:21 AM

Wow, major weirdness!?

I don't own a copy of Cubase 5 so I cannot give you any help with that. I would suggest that you take the debug versions of the *.dll's and try to step into the code. I know that may be somewhat daunting but once you know what methods are called you can start to analyze what is going on. Start by setting your breakpoints in the methods of the StdPluginCommandStub class that is located in the Plugin Namespace of the Jacobi.Vst.Framework assembly.

Or perhaps you can try to load the Core plugin sample? That sample displays the calls in its UI...